2008-10-11

Ubuntu 8.10 (Beta)

I had some extra time so I decided to upgrade my Ubuntu 8.04 to Ubuntu 8.10 Beta (codenamed Intrepid Ibex, would you believe it). My earlier pursuits with Ubuntu and my Acer 2920Z are detailed here for 7.10 and here for 8.04.

My first try to upgrade failed miserably. The reason was probably that I had selected a country specific server from program sources. I switched to the main server and tried again. This time everything seemed to go fine, but apparently it did not, as Gnome wouldn't load after reboot. My first try had probably messed something up. So, from console, I used apt-get to redo parts of the upgrade (I tried several commands, such as sudo apt-get update, upgrade, dist-upgrade, install, autoclean). After this Gnome loaded and everything seemed to be fine.

Everything, that is, except wlan. Madwifi drivers wouldn't work anymore. I had a look at the madwifi ticket for this chipset and learned that it was no longer necessary to use the hack I had been using earlier. The patch had been integrated to a madwifi branch. Unfortunately, this branch was not yet available from Ubuntu repositories, so it had to be installed manually. So I downloaded the new madwifi HAL, compiled and installed it (make, make install). After reboot wlan was working again.

It seems that after the upgrade the random problems with sound seem to be gone and, finally, the internal microphones are working. Incredibly, even TV-out works now. It was a struggle finding the correct settings for the displays, though. When mirroring screens the main laptop display was forced into a suboptimal resolution. Through trial and error, reboots, and turning mirroring off, I finally found a configuration which enabled me to watch video clips on my TV while surfing the net.

So, again, some minor problems with the upgrade, but nothing major. I'll update this entry if anything interesting happens.

15 comments:

Benjamin Auffarth said...

Thanks for the review. It is reassuring to hear that the upgrade leads to no major problems. I have been holding back the upgrade myself because the wlan fixes are not in the main branch, however I am very curious to see the changes.

journalman said...

am also using ubuntu (hardy at the moment) on an acer aspire 2920z. am still having troubles with the internal mic. i'm hoping to install intrepid in the next few weeks in the hope of resolving the problem.

Anonymous said...

Thanks for your great blog. I still don't have internal mic working.How did you enable it? Thanks

spicifer said...

Hi,

For me the internal mic "just worked" after the upgrade to 8.10. I would suggest checking a few things, though:

a) In file /etc/modprobe.d/alsa-base you probably still need to have the line "options snd-hda-intel model=acer"

b) Make sure that the internal mic channel is not muted in alsa mixer and also that you have set the internal mic as the default recording source.

If you do not see channels such as "Internal Mic Boost" in the mixer, then I'd suspect that Alsa hasn't recognised your sound HW and you probably need to edit the alsa-base file.

Giwex said...

Thanks a lot Spicifer. I didn't have that line alsa-base and, having messed a bit with the mixer, I got it working with Skype. However it is not recognized by application like Audacity so I have to work a bit more I think. Thanks so much!

Phoenix49 said...

I'm getting lags with my crystal eye camera with cheese application. Skype/Ekga works flawlessly, however Cheese and gstreamer test works very slow..

Olli said...

Hi again, I keep hearing good things about various laptop models' ram suspend features starting to work on 2.6.27 kernel, which is new to 8.10. What's the deal with 2920z?

spicifer said...

Actually, it seems that suspend is a lot better now. Unfortunately, at least for me, wlan doesn't seem to come back after suspend and I have to reboot to get it working.

Christian said...

Hi spicifer,

wlan does work after suspend, but the Gnome network manager ist really slow. Check if wlan is active (just click with the right mouse button on the symbol in the panel) and than type "sudo dhclient wlan0" in the terminal to get an IP address from your router. This should work.

Regards,
Christian

spicifer said...

Christian,

Thanks for the suggestion. I tried the command, but unfortunately it didn't seem to work for me. I don't know if it's just the network manager or what, but after resuming the machine can't see my wireless router or any other for that matter. Waiting for a while doesn't help.

I also tried turning wlan on and off from the manager, which didn't work either. I wonder if using ndiswrapper would give different results. (I wish I had some time to troubleshoot this further, but I have to leave it at that for now...)

Olli said...

I just installed 8.10, and everything works like a charm! I have the cheaper model of 2920Z, which lacks the internal wlan and bluetooth, so I don't have to deal with the abovementioned problems with suspend. Mic works now, too.

So that's it for me now, thanks a lot for your blog, it has been really helpful for me!

Christian said...

Spicifer,

OK, I think you have to bring your wlan card up after suspend with this command:

sudo ifup wlan0

Does this work for you?

spicifer said...

Christian,

Regrettably, no. I also tried ifdown -a and ifup -a just now, no luck. I also tried restarting the network manager applet and even dbus. Ethernet connection is fine though, so the problem seems to be limited to wlan.

For reference, here's what I get with ifup and iwconfig
$ sudo ifup wlan0
Ignoring unknown interface wlan0=wlan0.

$ sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

pan0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s Tx-Power:16 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
Rx invalid nwid:498647 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

$ sudo cat /var/run/network/ifstate
lo=lo
eth0=eth0

Now, it does occur to me that the problem may be the fact that in the past I have modified power saving settings, enabling laptop mode and such. Perhaps due to that the wireless device is not put to sleep correctly. So I might try next fiddling with my power saving settings. But I'm just guessing here. :)

Thanks a lot for the suggestion, though!

Anonymous said...

Hi Spica,

Your previous guides on Ubuntu on Acer 2920Z helped me to get out of a lot of trouble. And since I haven't found the answer elsewhere (even after reading 100s of Ubuntuforum posts) I will ask here. Have you managed to get your bluetooth working on this laptop? I have a pretty standard usb bluetooth dongle and since Intrepid it stopped working.

Thanks

Karel

spicifer said...

Hi Karel

Unfortunately I have no Bluetooth devices, so I'm unable to help with this one...

Good luck finding a solution!